Open in new window / Try shogun cloud
--- Log opened Sun Jan 12 00:00:48 2014
@sonney2kpickle27, ok easily fixed. just add    s/\\r//g; to the last perl thing00:59
@sonney2kjust next to the \\n/\n line00:59
* sonney2k off01:00
pickle27sonney2k: I was just fighting with perl to do the same thing!01:00
@sonney2kpickle27, try to be there on monday for the stammtisch :)01:01
* sonney2k Zzzzz...01:01
pickle27will do!01:01
-!- iglesiasg [~iglesiasg@524AE0A7.cm-4-3d.dynamic.ziggo.nl] has quit [Quit: Leaving]01:05
-!- pickle27 [~kevin@192-0-136-118.cpe.teksavvy.com] has quit [Quit: Leaving]02:56
-!- tricksy__ [uid12458@gateway/web/irccloud.com/x-tqegrjmczmcaudeo] has quit [Ping timeout: 272 seconds]02:56
-!- tricksy__ [uid12458@gateway/web/irccloud.com/x-jlahkdclumkmltig] has joined #shogun02:59
-!- sonne|osx [~sonne@e179136104.adsl.alicedsl.de] has quit [Ping timeout: 246 seconds]03:45
-!- sonne|osx_ [~sonne@e178247164.adsl.alicedsl.de] has joined #shogun03:45
shogun-buildbotbuild #678 of nightly_default is complete: Failure [failed test]  Build details are at http://buildbot.shogun-toolbox.org/builders/nightly_default/builds/67803:46
-!- thoralf [~thoralf@91-65-138-245-dynip.superkabel.de] has joined #shogun03:53
-!- thoralf [~thoralf@91-65-138-245-dynip.superkabel.de] has quit [Quit: Konversation terminated!]05:24
besser82sonney2k:  ping?11:09
besser82wiking:  could you solve bb's segfault-probs yesterday?11:09
besser82wiking:  or do we need to get that OSX-buildslave up && running again?11:10
besser82wiking, sonney2k: btw. Why is it down?11:10
-!- Netsplit *.net <-> *.split quits: sonne|osx_, dsockwell12:08
@wikingbesser82: broken12:42
besser82wiking:  b0rken? The buildbot?12:42
besser82wiking:  any chance to get that fixed?12:42
@wikingbesser82: no not the buildbot12:43
@wikingsomebody broke python modular12:43
besser82wiking:  mhhh...  but how?12:43
@wikingbut it's obvious12:43
@wikingit's currenlty broken on non osx system as well12:43
@wikingso there's not so much to it12:43
besser82wiking:  afaik noone touched that recently12:43
besser82wiking:  I didn't try from recent checkout...12:44
@wikinghttp://buildbot.shogun-toolbox.org/builders/deb3%20-%20modular_interfaces/builds/2130/steps/test%20python%20modular/logs/stdio12:44
@wikingthat's why the last commit broke it i suppose12:44
@wiking...12:44
@wikingbesser82: it was your commit that broke modular_interface bot: https://github.com/shogun-toolbox/shogun/commit/9eff7f380bc7c54f21a90c9318fc0d954ad3527812:45
@wikingso i suppose that actually it has been changed recently12:46
@wikingwhich actually broke the tests12:46
besser82wiking:  so my commit didn't break it, but revealed the truth  :-P12:46
@wikingso i cannot really comprehend with the sentence: "besser82> wiking:  afaik noone touched that recently"12:46
@wikingof course of course12:47
@wikinghow the fuck can i be soooo fucking stupid12:47
@wikingnot to understand this12:47
@wiking</sarcasm>12:47
besser82wiking:  :-P12:47
@wikingbesser82: let me get this straight12:48
@wikingthis was working in release 3.012:48
@wikingall of it12:48
@wikingit compiled both on modular_interface12:48
besser82wiking: yes12:48
-!- Netsplit over, joins: sonne|osx_12:48
@wikingand on osx12:48
@wikingso when u say12:48
@wiking12:46 < besser82> wiking:  so my commit didn't break it, but revealed the truth  :-P12:48
@wikingit's far from any kind of reality12:48
@wikingit got broken12:48
@wikingand your commit broke it on the buildbot12:49
@wikingi.e. you broke it12:49
besser82wiking: my commit just added the fact, that cmake should exit(1) if one of the intergration tests fail...12:49
@wikingso there's noooo fucking way around this but to see that it got broken recently with the .... *recent* changes.12:49
@wikingbesser82: yeah i see you totally get my point12:50
@wiking"12:47 <@wiking> this was working in release 3.0"12:50
@wikingw/o segfaulting on osx12:50
@wikingand i cannot really see it happening12:50
@wikingthat when u exit(1) a python script would segfault12:50
@wikingit's just really far stretch12:51
-!- dsockwell [~twgs@199.167.199.97] has joined #shogun12:51
@wikingwhere one would need to spend hours to arrive to that point12:51
@wikingwhere you get a segfault from exit(1)12:51
@wikingok?12:51
besser82wiking: kk12:52
besser82wiking: all I said was the interface itself wasn't touched for ~2 months12:52
besser82wiking: last commit was from sonney2k12:53
besser82wiking: and for me && sonney2k those python_modular isn't segfaulting on linux...12:53
besser82wiking: there must be another reason than just my commit to checkgdb....12:54
@wikingbesser82: ok do you want me to prove you wrong or can we just give me the benefit of the doubt (after like 5 times we've been over very similar things) and say that yes it got broken in recent commints12:54
@wiking*commits12:54
@wikingdude if it was working in release 3.012:54
@wikingthen if it's now broken12:54
@wikingthen i think it's ... quite possible that commits between now and 3.0 release broke it12:55
@sonney2kwiking, what is the issue?12:55
@wikingsonney2k: readlogs12:56
besser82wiking:  I don't say it isn't broken; but what about the 3.1.0 / 3.1.1 releases for OSX?  do they work?12:56
@wikingbesser82: obviously nobody knows this as it wasn't tested12:57
@sonney2kwiking, looks like the old stuff was broken before12:57
@wikingsonney2k: what old stuff?12:57
@sonney2kwiking, in 3.0 I mean but the tests just pretended to work12:57
@wikingsonney2k: no it was working12:58
@wikingsonney2k: i tested myself12:58
@wikingon my own machine12:58
@wikingi did not ever got segfaults12:58
@sonney2kwiking, for some reason the deb3 modular buildbot did not get triggered12:58
@wikingso plz can we get over this and arrive to the point where where we accept the facts?12:58
@wikingsonney2k: well it does not segfault12:58
@wikingso obviously it's a different problem12:59
@sonney2kwiking, well all that besser82 changed (before stuff broke) was to parse the output of the tests correctly so they fail when they did indeed. there is no segfault IIRC12:59
@wikingsonney2k: implication?12:59
@wikingit is a different bug12:59
@wikingbut again... it was working with 3.013:00
@sonney2kwiking, with osx I had that too - it is just due to using the wrong python version13:00
@wikingsonney2k: noup it's not13:00
@wikingsonney2k: but yeah i really like to waste both our times and make such a rookie error13:00
@sonney2kwiking, how do you know?13:00
@wikingsonney2k: because i fucking tested it13:00
@wikingcome on man13:00
besser82wiking:  How about testing 3.1.0 / 3.1.1 on OSX?13:00
besser82wiking:  if one of these segfault we can detect which commit possibly is the root cause...13:01
@wikingbesser82: you mean bisecting?13:01
@sonney2kwiking, well just building 3.1.1 shougl be enough13:02
@wikingsonney2k: glhf13:02
@wikingsonney2k: since obviously i have no clue at all how to do any of these things...13:02
@sonney2kwiking, btw could you easily add python_modualr tests on the osx buildbot?13:02
besser82wiking:  like that13:04
besser82wiking:  yes13:04
@wikingsonney2k: addig python_modular to osx buildbot will not solve anything python modular integration tests always failed on osx13:18
@wiking*adding13:18
shogun-buildbotbuild #341 of osx1 - libshogun is complete: Failure [failed test]  Build details are at http://buildbot.shogun-toolbox.org/builders/osx1%20-%20libshogun/builds/341  blamelist: Bj?rn Esser <bjoern.esser@gmail.com>, Soeren Sonnenburg <sonne@debian.org>, Thoralf Klein <thoralf.klein@zib.de>, Viktor Gal <vigsterkr@gmail.com>, hushell <dom343@gmail.com>, Koen van de Sande13:18
shogun-buildbot<koen@tibed.net>, parijat <mazumdarparijat@gmail.com>, Viktor Gal <viktor.gal@maeth.com>, Heiko Strathmann <heiko.strathmann@gmail.com>, Saurabh7 <saurabh.mahindre@gmail.com>, Fernando Iglesias <fernando.iglesiasg@gmail.com>, Roman Votyakov <votjakovr@gmail.com>13:18
-!- shogun-buildbot [~shogun-bu@7nn.de] has quit [Quit: buildmaster reconfigured: bot disconnecting]13:25
-!- shogun-buildbot [~shogun-bu@7nn.de] has joined #shogun13:25
-!- shogun-buildbot [~shogun-bu@7nn.de] has quit [Client Quit]13:26
-!- shogun-buildbot_ [~shogun-bu@7nn.de] has joined #shogun13:26
@sonney2kshogun-buildbot_, force build --branch=develop 'osx2 - python'13:26
shogun-buildbot_build #0 forced13:27
shogun-buildbot_I'll give a shout when the build finishes13:27
@sonney2kwiking, time to fix things then!13:27
@wikingsonney2k: well we've tried this like... soooo many times13:30
@wikingand we've figured that it's going to be very hard13:30
@wiking(check logs for details)13:30
@sonney2kwiking, yeah I know but we now use our own equals to compare things so we don't have the epsilon diff issues any longer13:31
shogun-buildbot_build #0 of osx2 - python is complete: Failure [failed test python modular]  Build details are at http://buildbot.shogun-toolbox.org/builders/osx2%20-%20python/builds/014:02
@wikingbesser82: ping?15:18
besser82wiking:  pong!15:20
besser82wiking:  wassup?!?15:20
@wikingbesser82: any experience with openstack?15:21
@wikingbesser82: i'm having trouble attaching a volume to an instance15:21
@wikingand i have no clue where to start debugging15:21
besser82wiking:  what type of volume?  persistent one?15:22
besser82wiking:  or transient one?15:22
@wikingbesser82: yeah it's a persistent volume15:22
@wikingbesser82: so i have an istance15:22
@wikingand then i've created a volume15:23
@wikingthe volume creation went successfully15:23
@wikingbut then when i try to attach that volume to a running instance15:23
@wikingit just gets stuck15:23
besser82wiking:  lemme ask nirik;  he was fighting with that problem, too, when creating our c-a in fedora-cloud  ;)15:23
@wikingand after a while it sends an error that it couldn't attach the volume15:23
@wikingthe admin of the system copy-pasted me an error but i can't even find the logfile for that error :)15:24
@wikingi have root acccess to the system and want to fix it asap15:24
besser82wiking:  exactly the same problem nirik had with fedora-cloud  ;)15:24
@wikingbut dunno where to start the debugging15:24
besser82wiking:  I'll start asking nirik, he knows / if he isn't araound i can ask mrunge tomorrow: he is one of the openStack developers...15:24
@wikingok i'll google then15:25
@wikingas i really need the solution yesterday :)15:25
-!- new_lido [~walid@41.218.178.11] has joined #shogun15:27
besser82wiking:  I just pinged nirik, asking for the solution....15:27
@wikingthnx if u have something let me know15:27
besser82wiking:  you may wish to have a look into #fedora-admin too see whether he responded...15:27
@wikingi'm trying to find the logs :)15:27
-!- new_lido [~walid@41.218.178.11] has quit [Ping timeout: 248 seconds]15:58
@wikingfuck for sure it's apparmor16:09
-!- new_lido [~walid@41.218.177.73] has joined #shogun16:09
-!- lisitsyn [~lisitsyn@80.252.20.67] has joined #shogun17:05
@sonney2klisitsyn, vojtech is in for gsoc too :)17:45
lisitsynsonney2k: cool17:45
@sonney2kwiking, might be of interest to you: vojtech did extend libqp quite a bit (more general more solvers...)17:45
lisitsynsonney2k: some qp I guess?17:46
lisitsyn:)17:46
@wikingsonney2k: where's da code?17:47
@wikingsonney2k: yeah but my idea is really a more modular/general interface for the whole optimization17:47
@wikingsonney2k: but would be great to include libqp in that as well17:48
@wikinganybody knows a little bit about virsh?17:48
@wikinglast release of libqp is 18-Jul-2012 11:1617:49
@wikingor at least on the website17:49
besser82wiking:  <nirik> besser82: in our case it was deleting a very large persistent volume... and the OS version we are running does a dd over it to wipe it and sucked up all i/o. Some instances needed to be restarted to see the net/storage after that finally finished. ;(17:50
@wikingbesser82: hehehe same in my case17:50
besser82wiking:  :D17:50
@wikingbesser82: but now the problem is that i suspsect that a kvm instance has been stuck in17:50
@wikingi see the kvm process but not on the openstack ui17:51
@wikingbut before killing the instance17:51
@wikingi would really like to see what's that instance17:51
@wikingvirtsh sees it17:51
@wikingbut dunno how i can use virtsh to echo the /etc/hostname17:51
-!- iglesiasg [~iglesiasg@524AE0A7.cm-4-3d.dynamic.ziggo.nl] has joined #shogun18:15
-!- mode/#shogun [+o iglesiasg] by ChanServ18:15
besser82iglesiasg:  sup, man?18:22
@iglesiasgbesser82, hey there18:22
besser82iglesiasg:  :D18:22
@wikingppppp wtf is the ssh tunneling command? -L18:24
@wikingbesser82: there's a port bind to localhost only... but i want to access it remotely?18:25
@wikingbesser82: ssh -RlocalhostPort:myport?18:25
besser82wiking:  ssh -Lremoteport:localhost:myport  ;)18:25
@wikingbesser82: noup18:26
besser82wiking:  sry, my bad18:26
@wikingi mean on the remote's localhost there's a port18:26
@wikingthat i want to have it on my own localhost18:27
@wikingok it's the other way around i think18:28
@wikinghuuu fuck i was right :)18:30
besser82wiking:  so how did you do it?18:31
@wikingnah i was right about being the other way around aht that a kvm instance got stuck18:31
@wiking:)18:31
@wikingit's18:31
@wiking-LportUmap:localhost:desiredPort18:32
@wikingdoh i cannot send a ctrl+alt del18:32
@wikingto that vnc session18:32
besser82wiking:  why don't you use virtsh to trigger a reboot on that machine?18:33
@wikingyeah actually i just needed this to assure myself that it's an instance i was thinking about18:33
besser82wiking:  I see  ;)18:33
@wikingmmmm18:37
@wikingbesser82: what happens when virsh shutdown domainid does not stup the instance? :)18:37
besser82wiking:  basically nuthing18:37
besser82wiking:  virsh tries to shutdown sending an acpi event18:38
@wikingbesser82: ok reset works18:38
@wikingbut still i just want to destroy this domain18:38
besser82wiking:  reset is the "brutal" way18:38
@wikingbesser82: but it's really in a weird place this whole libvirt18:39
@wikinganyhow as i can see virsh destroy will be the one18:39
besser82wiking:  ??18:39
@wiking           Immediately terminate the domain domain-id.  This doesn't give the domain OS any chance to react, and it's the equivalent of ripping the power cord out on a18:39
besser82wiking:  that is the way you need to go, if guest doesn't act on acpi-events...  :(18:40
@wikingbesser82: well on reset it does but nothing else18:40
besser82wiking:  reset is like pushing the hw-button  ;)18:41
@wikinggreat18:41
@wiking -     instance-0000122b              shut off18:41
@wiking:>18:41
besser82wiking:  :D18:41
@wikingbut is this really deleted/destroyed?18:41
besser82wiking:  no, just shutdown, like pulling the cord18:42
besser82wiking:  undefine would delete it "physically"18:43
besser82wiking:  like throwing the device into waste-bin18:43
@wikingbesser82: other thing: when u try to do screen -r with another use (i.e. not the user who owns the pts) how do u resolve it? (Cannot open your terminal '/dev/pts/30' - please check.)18:49
besser82wiking:  try using sudo?18:49
@wikingbesser82: yep that's the error18:50
@wikingboth for sudo su -18:50
@wikingand sudo -u user -i18:50
besser82did you try su -c 'sudo -u user -i'  ?18:51
@wikingsame18:52
@wikingjust an extra error:18:52
@wiking-bash: no job control in this shell18:52
besser82wiking:  sh*T18:52
@wikingnevermind solved it by adding my public key to that user18:52
@wiking:P18:52
besser82wiking:  did you try to chmod the perms to 660  ?18:52
besser82wiking:  or that solution  ;)18:53
@wikingok finally an error log18:59
@wikinghttp://pastebin.com/rnQ8M1jJ18:59
@wikingbesser82: can u ask about this niri?18:59
besser82wiking:  done ;) w8ing 4 reply19:14
besser82wiking:  if he doesn't know, I will ask mrunge tomorrow. An openStack-dev should know about && why...19:14
besser82<nirik> besser82: hum... is tgtd running ok on all the compute nodes? firewall allowing it? Otherwise not sure, haven't seen that before...  <--- wiking19:18
besser82wiking:  Sry, I couldn't help instantly with that...19:22
@wikingkkk19:25
@wikingtgtd is running apparently19:25
@wikingi though that apparmor is fucking up things19:26
@wikingbut i totally disabled it19:26
besser82wiking:  firewall? what about that?19:27
@wikingbesser82: which ? :)19:27
@wikingi mean the whole thing is running on one machine :)19:27
besser82wiking:  hehe, so no fw, right?19:27
besser82wiking:  I'll ask mrunge tommorow, he should know what's going b0rken there19:28
besser82wiking:  btw. pastebin-ad tells me I urgently need to fix my "WindowsErrors" on Linux  :-P19:28
* besser82 off [Zzzzz]19:41
@wikingbesser82: thnx i think i've encountered this bug: https://bugzilla.redhat.com/show_bug.cgi?id=100929921:16
-!- shogun-buildbot_ [~shogun-bu@7nn.de] has quit [Quit: buildmaster reconfigured: bot disconnecting]21:34
-!- shogun-buildbot [~shogun-bu@7nn.de] has joined #shogun21:34
@sonney2kshogun-buildbot_, force build --branch=develop 'osx2 - python'21:34
@sonney2kshogun-buildbot, force build --branch=develop 'osx2 - python'21:35
shogun-buildbotbuild #1 forced21:35
shogun-buildbotI'll give a shout when the build finishes21:35
@sonney2kwiking, any idea why no tests for python static are found http://buildbot.shogun-toolbox.org/builders/osx2%20-%20python/builds/0/steps/test%20python%20static/logs/stdio21:39
-!- pickle27 [~kevin@192-0-136-118.cpe.teksavvy.com] has joined #shogun21:40
-!- zxtx_ [~zv@c-98-223-196-32.hsd1.in.comcast.net] has quit [Ping timeout: 272 seconds]21:43
@wikingsonney2k: so where's the src for the libqp enhancements? :)21:45
@wikingbecause they are not created imho21:45
@wiking-rw-r--r-- 1 wiking staff 0 Oct 25 16:53 examples/undocumented/python_static/CMakeLists.txt21:47
shogun-buildbotbuild #1 of osx2 - python is complete: Failure [failed test libshogun test python modular]  Build details are at http://buildbot.shogun-toolbox.org/builders/osx2%20-%20python/builds/121:56
@iglesiasggood night guys22:59
-!- iglesiasg [~iglesiasg@524AE0A7.cm-4-3d.dynamic.ziggo.nl] has quit [Quit: Leaving]23:00
-!- pickle27 [~kevin@192-0-136-118.cpe.teksavvy.com] has quit [Quit: Leaving]23:06
-!- shogun-buildbot [~shogun-bu@7nn.de] has quit [Quit: buildmaster reconfigured: bot disconnecting]23:13
-!- shogun-buildbot [~shogun-bu@7nn.de] has joined #shogun23:13
@sonney2kshogun-buildbot, force build --branch=develop 'osx2 - python'23:13
shogun-buildbotbuild #2 forced23:13
shogun-buildbotI'll give a shout when the build finishes23:13
shogun-buildbotbuild #2 of osx2 - python is complete: Failure [failed test python modular]  Build details are at http://buildbot.shogun-toolbox.org/builders/osx2%20-%20python/builds/223:35
--- Log closed Mon Jan 13 00:00:50 2014